Take the 2-minute tour ×
Bitcoin Stack Exchange is a question and answer site for Bitcoin crypto-currency enthusiasts. It's 100% free, no registration required.

I am following this guide: http://rdmsnippets.com/2013/03/20/bitcoin-mining-with-ubuntu-12-04-tls-and-cgminer/

But it won't work on my server (Specification's are in the Subject-field)

I get this error:

koen@gorgabal-Server:~/bitcoinmining$ ./cgminer/cgminer -n
 [2013-06-23 15:03:51] CL Platform 0 vendor: Advanced Micro Devices, Inc.                    
 [2013-06-23 15:03:51] CL Platform 0 name: AMD Accelerated Parallel Processing                    
 [2013-06-23 15:03:51] CL Platform 0 version: OpenCL 1.2 AMD-APP (1113.2)                    
 [2013-06-23 15:03:51] Error -1: Getting Device IDs (num)                    
 [2013-06-23 15:03:51] clDevicesNum returned error, no GPUs usable                    
 [2013-06-23 15:03:51] 0 GPU devices max detected                    
koen@gorgabal-Server:~/bitcoinmining$ sudo aticonfig --lsa
* 0. 01:00.0 ATI Radeon HD 3600 Series

* - Default adapter

I can't switch to windows because of several reasons, does anybody have an idea of what I am doing wrong?

Thanks in advance! ps: I have used linux for several years now, so I know my way around. This is a fresh server installation.

share|improve this question
add comment

2 Answers

OpenCL is not supported on 3xxx series cards. Although it's not completely impossible to mine on a card that old it will be very difficult. Also, a card that old will produce less than 1 MH/s which will only be fractions of bitcoins. I wouldn't waste my time fighting the Radeon 3600.

If you are serious about mining check out the 5xxx and 7xxx series cards. Or better yet, look into ASICs.

share|improve this answer
add comment

I was myself unable to run completely headless. For some reason the ATI driver needs an XServer running.

Once you have an XServer running you still need to tell cgminer where to find it, setting the DISPLAY env variable takes care of this:

export DISPLAY=0.0

this though only takes care of the first ATI card. A little trick is not to specify the second part of the identifier:

export DISPLAY=0

this should let you at least find all the cards. Next you need to configure your XServer to make use of all present cards:

DISPLAY=0 aticonfig --initial --adapter=all -f

Notice that prefixing commands with the env-variable setting works as well. Next you restart the XServer and test that it works:

DISPLAY=0 aticonfig --adapter=all --od-gt

This should give you the temperatures for all cards you have installed. From there, you should be able to start cgminer and it should detect the cards:

DISPLAY=0 ./cgminer/cgminer -n
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.