Take the 2-minute tour ×
Bitcoin Stack Exchange is a question and answer site for Bitcoin crypto-currency enthusiasts. It's 100% free, no registration required.

I've downloaded the Windows 64-bit Litecoin mining software as provided from http://pool-x.eu/gettingstarted

I'm trying to run the miner from behind a firewall. My browser uses an HTTP proxy to get to the internet, and as I understand it I should be able to use a similar method to connect my Litecoin miner to a pool.

So far, I've modified the file start.console.bat from:

@echo off

START /LOW /B minerd.exe --algo scrypt --url http://litecoinpool.org:9332/ --userpass username.1:1 --threads 4 -r -1 -s 5

to:

@echo off
set HTTP_PROXY=http://myproxyserver:myport
START /LOW /B minerd.exe --algo scrypt --url http://litecoinpool.org:9332/ --userpass myusername.1:mypassword --threads 4 -r -1 -s 5

I've substituted my values in to take the place of the following values: myproxyserver myport 9332 myusername.1 mypassword

When I try using the port my browser uses for the proxy server (for both port values), I get this output when I run it (and it spits out another error every 30 secs):

[2012-07-07 13:57:48] HTTP request failed: The requested URL returned error: 503

[2012-07-07 13:57:48] json_rpc_call failed, retry after 30 seconds
[2012-07-07 13:57:48] 1 miner threads started, using 'scrypt' algorithm.

Should the port number for the proxy and for the mining script be the same? What settings can I use to get my miner working?

share|improve this question
    
This question is related but not identical: bitcoin.stackexchange.com/q/4014/516 –  Highly Irregular Jul 7 '12 at 2:21

1 Answer 1

up vote 1 down vote accepted

I got it working for pool-x.eu connecting via port 80 (the proxy server name and port is just what my browser uses):

@echo off
set HTTP_PROXY=http://myproxyserver:myport
START /LOW /B minerd.exe --algo scrypt --url http://mine.pool-x.eu:80/ --userpass myusername.1:mypassword --threads 4 -r -1 -s 5

Not all pools allow connections through port 80, so it does limit which pools you can connect to.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.