Take the 2-minute tour ×
Bitcoin Stack Exchange is a question and answer site for Bitcoin crypto-currency enthusiasts. It's 100% free, no registration required.

I am running the standard client on a micro Amazon EC2 instance. When I am synchronising Bitcoin with the network, it uses about 50% of the available CPU. After it is fully synchronised, I leave it alone and it cranks up to 100% by itself.

What can be causing the standard client to behave in this manner? Is it due to possibly high transaction volume, sharing information with peers, or perhaps something else?

share|improve this question
1  
During synchronization, especially on virtual hardware, most of the time is spent on waiting for I/O, not verification. This will likely change in 0.8 (LevelDB does a better job minizing I/O). –  Pieter Wuille Nov 10 '12 at 13:58
    
How many connections does it have? i.e, are there a bunch of peers pulling from you? Does limiting it to only 8 (i.e., disable incoming or -maxconnections) change the behavior? –  Stephen Gornick Nov 10 '12 at 20:15
1  
@StephenGornick Initially I thought it was the peers to, but I closed my port 8333 and it was still doing that. I'm guessing it might be caused by Bitcoin memory leakage building up over time and Amazon limiting the CPU cycles for micro instances. After a full system restart the problem appears to have gone away for now. –  ThePiachu Nov 10 '12 at 20:49
    
Running bitcoin-qt 0.8.1 on non-virtualised hardware and when synchronised and otherwise idle it still pegs all cpus it can find. Not good. –  user3786 Apr 1 '13 at 20:41
    
I would re-check the bitcoin.conf to see if it has the line gen=0 ( not create coin ) and add it if it is not present, change to zero if it is there and set to 1. On non-virtual and one virtual ( windows based virtual pc ) having it in there and set to 0 dropped the cpu cycles to idle levels. –  nybbler905 Aug 23 '13 at 19:42

1 Answer 1

No, according to the information on small and micro instances at this link. http://docs.aws.amazon.com/AWSEC2/latest/UserGuide/concepts_micro_instances.html Bitcoin.conf ( the Bitcoin Configuration file ) may have an option set to 1 to activate mining within the client software. If you have it set as ' gen=1 ' it will try and ' generate ' coins ( mine on it's own ) and that drives CPU usage up. Also, according to the graphs on that link, it should not ' jump ' to 100 percent use, each instance should drop down to a low usage level for small and micro Amazon EC2 instances. There may be other programs running on your Amazon EC2 instance that can also drive up CPU usage so I recommend checking your files starting with looking for any instance of Minerd ( cpu miner ) and removing it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.