Take the 2-minute tour ×
Bitcoin Stack Exchange is a question and answer site for Bitcoin crypto-currency enthusiasts. It's 100% free, no registration required.

I am trying to setup a private test net with the source at: https://github.com/freewil/bitcoin-testnet-box

However, it requires bitcoind 0.7.2 (the latest version is 0.8.0).

I tried installing 0.7.2 with the following:

wget http://sourceforge.net/projects/bitcoin/files/Bitcoin/bitcoin-0.7.2/bitcoin-0.7.2-linux.tar.gz/download

but then get the following errors when I install:

sudo dpkg -i bitcoind_0.7.2-3_amd64.deb 

Selecting previously unselected package bitcoind.
(Reading database ... 65728 files and directories currently installed.)
Unpacking bitcoind (from bitcoind_0.7.2-3_amd64.deb) ...
dpkg: dependency problems prevent configuration of bitcoind:
 bitcoind depends on libboost-filesystem1.49.0 (>= 1.49.0-1); however:
  Package libboost-filesystem1.49.0 is not installed.
 bitcoind depends on libboost-program-options1.49.0 (>= 1.49.0-1); however:
  Package libboost-program-options1.49.0 is not installed.
 bitcoind depends on libboost-system1.49.0 (>= 1.49.0-1); however:
  Package libboost-system1.49.0 is not installed.
 bitcoind depends on libboost-thread1.49.0 (>= 1.49.0-1); however:
  Package libboost-thread1.49.0 is not installed.
 bitcoind depends on libdb5.1++; however:
  Package libdb5.1++ is not installed.
dpkg: error processing bitcoind (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db ...
Errors were encountered while processing:
 bitcoind

Following with

sudo apt-get -f install

Still gives these errors:

dpkg: dependency problems prevent configuration of bitcoind:
 bitcoind depends on libboost-filesystem1.49.0 (>= 1.49.0-1); however:
  Package libboost-filesystem1.49.0 is not installed.
 bitcoind depends on libboost-program-options1.49.0 (>= 1.49.0-1); however:
  Package libboost-program-options1.49.0 is not installed.
 bitcoind depends on libboost-system1.49.0 (>= 1.49.0-1); however:
  Package libboost-system1.49.0 is not installed.
 bitcoind depends on libboost-thread1.49.0 (>= 1.49.0-1); however:
  Package libboost-thread1.49.0 is not installed.
 bitcoind depends on libdb5.1++; however:
  Package libdb5.1++ is not installed.
dpkg: error processing bitcoind (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 bitcoind

I can't seem to figure out how to install these packages with apt-get even though they are listed here:

http://packages.ubuntu.com/quantal-updates/libboost-filesystem1.49.0

Edit: This may be of help, though I haven't gotten it completely working yet:

http://askubuntu.com/questions/168053/how-to-install-all-the-boost-development-libraries
share|improve this question
    
Zen, it looks like linebreaks are missing from the first error message. Is that the correct message? –  Nick ODell Feb 26 '13 at 20:31
    
Fixed it. I guess it needed to be copied and pasted as code. Still the same error message though. –  ZenBalance Feb 26 '13 at 22:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.