Take the 2-minute tour ×
Bitcoin Stack Exchange is a question and answer site for Bitcoin crypto-currency enthusiasts. It's 100% free, no registration required.

I recently switched to CGminer from phoenix from GUIminer. And seem to be having some issues.

System: Windows 7 64bit, x4 5830's

-Timeline- AMD catalyst: 13.1 GPUs: 5830x2 7770x1 Miner: CGminer newest stable release 10.5 I think. Sum: Worked well except for flashing squares on the screen when mining and using the desktop. Saw a post that said update catalyst to 13.2 for no squares.

~~Changelog: updated to 13.2 catalyst, returned the 7770 (money issues)

AMD catalyst: 13.1 GPUs: 5830x2 Miner: CGminer newest stable release 10.5 Sum: Works well for a few hours (the upgrade to 13.2 also removed the squares), then I either get a DEAD thread for the gpu doing the desktop, or I cannot get windows to return to desktop after it sleeps, or just a good 'ol BSOD.

I was reading around and it said that CGminer makes some binaries on initial run and only initial run. So do those binaries contain info about old 7770 that I removed and now it is conflicting somehow? Should I just reinstall CGminer?

Or do people know of issues with the 13.2 CataContCent?

OP EDIT: test config 1

{
"pools" : [
    {
        "url" : "stratum.btcguild.com:3333",
        "user" : "MY USER",
        "pass" : "MY PASS"
    }
],
"intensity" : "d,9,9,9",
"temp-cutoff" : "95,95,95,95",
"temp-overheat" : "85,85,85,85",
"temp-target" : "75,75,75,75",
}

What I want my conf to do. Put the three 5830's not doing the desktop balls to the wall. The one I am using for desktop try and do the best it can but do not interfere with desktop. Turn off any GPU that hits 95C, try to run them all at 75C.

No overclock on any GPU. I do not wish to slow them down or speed them up yet. I just want them to run without crashing my system first. I don't care about fanspeed/noise.

How do I know my 'd' setting will hit GPU0 (my desktop)?

Any other important settings that I removed?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Try to lower GPU clock a little bit to let's say 900MHZ or stock, and also make sure that the memory clock is not lower than 300MHZ. After that try to keep an eye on the GPU temperatures as this may be the cause of the sudden BSOD. Also there is a intensity parameter, if you keep it as 9 then try to lower it to 7. My config for 5830 looks like this:

{
"pools" : [
    {
        "url" : "mint.bitminter.com:8332",
        "user" : "username_workername",
        "pass" : "worker_password"
    }
],
"intensity" : "9,9,9,9",
"gpu-engine" : "0-950,0-950,0-950,0-870",
"gpu-fan" : "0-85,0-85,0-85,0-85",
"gpu-memclock" : "300,300,300,300",
"gpu-powertune" : "20,20,20,20",
"temp-cutoff" : "95,95,95,95",
"temp-overheat" : "85,85,85,85",
"temp-target" : "80,75,75,80",

"algo" : "4way",
"auto-fan" : true,
"auto-gpu" : true,
"expiry" : "120",
"failover-only" : true,
"gpu-threads" : "2",
"log" : "5",
"queue" : "1",
"retry-pause" : "5",
"scan-time" : "60",
"temp-hysteresis" : "3",
"worksize" : "0",

"donation" : "0.00",
"shares" : "0",
"kernel-path" : "/usr/local/bin"
}

and works for over a year now :)

share|improve this answer
    
I need to write my own config file first too I guess. I think my problem lies in reinstalling CGminer though. This log file you posted, it is for 4 5830's right? Could you post the entire file? –  BumSkeeter Mar 4 '13 at 18:00
    
What version of Catalyst and CGminer do you have also? –  BumSkeeter Mar 4 '13 at 18:01
    
Could I send you my config file I am about to write here in a few mins and see if it is proper? –  BumSkeeter Mar 4 '13 at 18:05
    
I have edited my answer and included whole file. Yes, this is for 4 graphic cards, if you want less then simply remove additional values. Catalyst 11.6 (year ago), AMD SDK 2.5. Installing newer catalyst was causing a lot of problems in my case. Newer drivers works fine with 7970 cards but with 5830 I decided to stick with 11.6. Still getting roughly 310mhash –  Sephiroth Mar 4 '13 at 18:06
    
Well, I guess I cannot PM you. I will post my config in the OP. Look it over if you would. –  BumSkeeter Mar 4 '13 at 18:09
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.