2

So I've setup my own Pushpool server, and now I'm trying to connect using GUIMiner

The server is up and running, this is what my terminal says:

sbin/pushpoold -E -F
[2013-04-19 20:33:5.395392] Listening on host :: port 8336
[2013-04-19 20:33:5.395592] Listening on host :: port 8337
[2013-04-19 20:33:5.395792] initialized

and on the GUIminer I connect with

Host: http://localhost
Port: 8336
Username: username (what I have set in SQLite3)
Password: password

But then when I start mining my console says this

2013-04-18 14:40:53: Running command: poclbm.exe username:password@http://localhost:8336 --device=0 --platform=0 --verbose -r1 
2013-04-18 14:40:53: Listener for "Default" started
2013-04-18 14:40:54: Listener for "Default": 18/04/2013 14:40:54,  need more than 1 value to unpack
2013-04-18 14:40:56: Listener for "Default": WARNING: ADL missing (no AMD platform?), temperature control is disabled
2013-04-18 14:40:56: Listener for "Default": At least one server is required
2013-04-18 14:40:56: Listener for "Default": Traceback (most recent call last):
2013-04-18 14:40:56: Listener for "Default": File "Switch.pyo", line 45, in __init__
2013-04-18 14:40:56: Listener for "Default": File "Switch.pyo", line 60, in parse_server
2013-04-18 14:40:56: Listener for "Default": ValueError: need more than 1 value to unpack
2013-04-18 14:40:57: Listener for "Default" shutting down

Anybody here have any idea on how to fix this? Thanks.

1

You're adding the server the wrong way. The way you note the server's address isn't valid URI syntax.

Bad :

username:password@http://localhost:8336

Good :

http://username:password@localhost:8336

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.