0

I want to connect my Electrum wallet app to my private Electrs server in my local LAN which is also reachable via onion. I want to just use this one server, no other server. My ~/.electrum/config is

{
    "alias": "",
    "auto_connect": false,
    "blockchain_preferred_block": {
        "hash": "000000000019d6689c085ae165831e934ff763ae46a2a6c172b3f1b60a8ce26f",
        "height": 0
    },
    "check_updates": true,
    "config_version": 3,
    "gui_last_wallet": "/Users/$USER/.electrum/wallets/default_wallet",
    "is_maximized": false,
    "oneserver": false,
    "proxy": "socks5:127.0.0.1:9050::",
    "recently_open": [
        "/Users/$USER/.electrum/wallets/default_wallet"
    ],
    "rpcpassword": "",
    "rpcuser": "",
    "server": "something.onion:50002:s",
    "show_channels_tab": true
}

This seems to work fine in the sense that I am connected. But I have a lot of nodes in my list under the "Network" settings in Electrum. And this is because the oneserver property is set to false. If I try to set it to true in the config manually, Electrum starts and works fine but the config file is reverted to its old state with false in it.

How can I make sure this works?

1 Answer 1

0

I don't know why this happened several times. But in the end the config worked with true and now my nodes show only one connection and this is the private server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.