on the new wallet I created the button for 'create new receiving address' is greyed out. I've tried looking for answers over several places but most the guides and posts are outdated.

Also the wallet says its encrypted and locked, and on 0.20.1 There does not seem to be an unlock button under 'File' or 'Settings'. I did try to make a send txn where it asked the passphrase to unlock, but given there's no bitcoin in the wallet it failed, but I tried this to see if I could unlock the wallet.

Please help, the default wallet and a new wallet I created (without a passphrase) have no issues on generating a new receiving address, however this encrypted one, I can't click the button to generate a new receiving address, and I can't understand why. I've also enabled 'coin control features'.


  • 1
    I fixed it by running 'getnewaddress' on the RPC console of that wallet. I don't know how or why! but the button to 'create new receiving address' is no longer greyed out! Wooo! Commented Dec 25, 2020 at 22:23

2 Answers 2


This issue is reported in https://github.com/bitcoin-core/gui/issues/105 and fixed in https://github.com/bitcoin/bitcoin/pull/20230


Dont check the 'Make blank wallet' option when creating a new wallet. Blank wallets don't initially have private keys or addresses, those can only be imported. Having the new wallet encrypted or not has no effect on the ability to create a receiving address.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.