0

so i have bfgminer up on a linux machine running fine purring away at 67Mh/s solo mining (geforce gtx460)

im attempting to build on a windows 10 machine

i have tried msys2 mgwin32 and 64 bit

nothing seems to work i get errors in all stages: autogen, configure and make

im using mgwin64bit now and got to the make stage succesfully...

i am able to autogen, configure but when it comes to make i get an error:

make[3]: Leaving directory '/home/virtu/bfgminer/libblkmaker'
  CCLD     bfgminer.exe
C:/msys64/mingw64/bin/../lib/gcc/x86_64-w64-mingw32/10.2.0/../../../../x86_64-w64-mingw32/bin/ld.exe: bfgminer-miner.o:miner.c:(.rdata$.refptr.cpus[.refptr.cpus]+0x0): undefined reference to `cpus'
collect2.exe: error: ld returned 1 exit status
make[2]: *** [Makefile:1340: bfgminer.exe] Error 1
make[2]: Leaving directory '/home/virtu/bfgminer'
make[1]: *** [Makefile:2844: all-recursive] Error 1
make[1]: Leaving directory '/home/virtu/bfgminer'
make: *** [Makefile:1209: all] Error 2

Could someone help me come up with a solution?

in the meantime i will return to mingw32 and attempt to fix the no gcc or c compatible compiler issue on autogen/configure

1

error in miner file, something to do with cpus

./configure with enable cpu mining fixed this

now able to make bfgminer

note similar issue from other users:

https://github.com/luke-jr/bfgminer/issues/787

1
  • ./configure --enable-cpumining && make
    – Ali ISSA
    Feb 6 at 17:40
0

./configure --enable-cpumining && make

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.