1

Kind of a long story, I'll try to be consice -

  1. Back in 2013 I've opened 2 wallets at blockchain.com (back then it was blockchain.info) and I have funds in both wallets.
  2. Tried to access the wallets about 3 years ago. Everything was OK with the first one, but when I've tried to access the second wallet, I did not got the confirmation mail from the site.
  3. After some help from their support, I've figured that I've used 2 different mail accounts to the wallets and I don't have access to the second mail anymore.
  4. I've asked the support team to change my 2FA mail of the second wallet to the mail address that I use today, which they did.
  5. After the change was done, I tried again to access the wallet. I got the confirmation mail, but when I clicked it, the login page displayed the sad message of "Cannot decrypt wallet, wrong password", although I'm sure I have the correct password (read on and understand howcome I'm so sure).
  6. Tried to use the recovery phrase - the recovery page asked my 12 words phrase, while mine is 17 words.
  7. Wrote to the support once again, and they reffered me to a different recovery page, one that uses 17 words, since my wallet is now considered "legacy" wallet.
  8. Recovered the password and guess what? It is the exact password that I have. I've double and triple checked it, but it is the same password.
  9. Once again I've tried the support team, but all the responses that I got where the same - we don't store the passwords and we cannot help you.
  10. Found recently the wallet.aes.json file of that wallet, I've decrypted it (using python script from this site. I've use my password and the file was decrypted correctly, showing my my public address, wallet guid and some other data.

To conclude - It looks to me that something went wrong with the site's copy of my wallet - either in the process of upgrading the site (even though my second wallet is OK), or in the process of changing my 2FA mail address), but they won't help me anymore.

My question -
What should I do next?
I know that there is an option to "import" my wallet.aes file to the site, with this link, but is it the right thing to do? The wallet is already in their database, so can it be "imported"?
Can I import that file to another site and gain access to my wallet? Thanks :)

1
  • 10. that other data you decrypted does also contain your private key, unfortunately not in WIF. you should convert it and import to Electrum, then have your funds. – KeychainX Feb 18 at 23:55