0

I have had Bitcoin Core on this computer before, and it worked fine for over a year with no trouble. I had recently uninstalled it, and today attempted to re-install, but, after running setup, on attempting to open bitcoin-qt.exe, the following error appears:

Assertion failed! Program: C:\Program Files\Bitcoin\bitcoin-qt.exe File: wallet/scriptpubkeyman.cpp, Line 720 Expression: mapKeys.empty()

...with three options, Abort, Retry, and Ignore. This happens consistently.

I am running bitcoin-0.20.1-win64, Windows 10. I have tried further uninstalling and reinstalling, and installing in both a C:\ and D:\ drive. Running from the command prompt with -rescan does not help either.

Any assistance would be very much appreciated.

  • I think bug reports belong to github.com/bitcoin/bitcoin/issues – MCCCS Jan 11 at 17:28
  • 1
    This indicates that your wallet file is corrupted. This error happens when the wallet contains both encrypted and unencrypted keys. Is your wallet encrypted? Did you try to encrypt it recently? – Andrew Chow Jan 12 at 0:15
  • I didn't try to encrypt it, but you were correct that the wallet.dat file was the problem - as I was re-installing Bitcoin Core in a different folder, I didn't realize the old wallet.dat would still be recognized. I've moved the old wallet.dat to a USB stick and now the program runs with no issue. – Max Jan 12 at 2:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.