0

Yesterday, I dug up my old computer, set it up physically, installed Linux Mint with full disk encryption, installed Bitcoin Core through its software manager, started it, immediately selected "pruned mode" in the settings (kept it at default 2 GB since I have no idea if it's good or bad to increase/decrease it), closed it and started it again, to let it sync from scratch to 100%...

When I went to bed, it seemed awfully unresponsive, with mouse movements taking several seconds before they showed up on the screen. When I woke up, and looked at the progress, it was still at 21%, with "10 weeks left". It now would not at all react to any attempts to close it or click on anything. I had to "hard-cut" the power to the machine and restart it. It's been running in the same sluggish, unresponsive state, still stuck at 27.x%, since.

Today, after desperately reading online for a solution, I changed the default "dbcache" to 6000 MB as somebody online said was the maximum where it matters. Seems to have no difference.

It's connected directly to 100/100 Mb/s fiber, and the hardware is 3 GB RAM and a 2011-era Intel CPU of 3 GHz or so. Dual core something. The HDD is 250 GB and mechanical. (Which is why it was not a choice to store the entire blockchain and I had to use pruned mode right away.)

It's a noisy, clunky machine which takes up a lot of space, and I really need to set up this wallet. It's important. This whole process is really dragging on and on and I did not expect this extreme slowness. I really can't express how frustrating this is. I don't get what the problem is. This isn't ancient hardware. It's just a few years old. And it's not a budget/cheap machine like a Raspberry Pi or something. Why is it going so insanely slowly?

Looking at the Linux Mint GUI tool to see system usage, it doesn't even seem to be using much of the CPU cores, but does write and read a lot on the disk... But it's always unclear (regardless of the OS) what actually is happening.

And reading online, apparently, Bitcoin Core has become much more efficient with syncing over the years! Perhaps it's offset by the increasing size of the blockchain? Either way, this is truly unbearable, and I don't know how much longer I can go on looking at that screen which seems to be forever stuck at "4 years and 13 weeks behind"...

I'd hate to have to give up and forget about it, but I have a feeling that even the "4 weeks" may increase further and that it's just going to take longer and longer. I expected it to be on overnight and perhaps most of today. Not weeks upon weeks with seemingly no progress being made after ~27%...

Oddly, even with the recent surge, this Bitcoin category on SE seems completely dead. I have no idea what people are doing, but they certainly don't seem to be looking for Bitcoin questions to answer...

9
  • What are you planning to use Core for?
    – MCCCS
    Jan 18 at 17:49
  • @MCCCS To securely (compared to doing it on my Windows 10 machine which I'm typing this on and which has a fully synced Bitcoin Core) set up a new wallet and encrypt it and then store that encrypted wallet.dat in many redundant backups.
    – Leif
    Jan 18 at 17:51
  • You can add your working node to your older computer which will then sync faster. Would this solve your problem?
    – MCCCS
    Jan 18 at 17:52
  • 1
    So, against your scardness, open the console in your wallet computer do dumpprivkey <addr> and unless it gives an error, you can be sure that your wallet.dat has your private key/will have your coins. You can then send your coins safely.
    – MCCCS
    Jan 18 at 18:00
  • 1
    If you only have 3 GB of RAM, then setting the dbcache to 6 GB is going to make matters a lot worse. Synchronization is very database-intensive (constantly looking up things and writing updating entries back); on a system with slow disk operations this is going to be painful if you don't have enough RAM to cache significant parts of it. Pruning also slows things down, as it requires a database flush every time files are deleted. Jan 18 at 20:04
0

It sound’s like the bottleneck is I/O on your hard drive. A couple of suggestions:

  1. Copy the data directory from you other machine which you have already synced, this will skip you the initial sync entirely.

  2. A lot of read/write is happening in the chainstate directory and full disk encryption probably doesn’t help. You can move the chainstate directory (around 3GB) to an SSD. If your computer doesn't have an SSD you can use an SSD thumb drive. There are instructions on how to do that here

2
  • You didn't read what I said. 250 GB HDD = impossible to copy over files.
    – Leif
    Jan 18 at 22:51
  • Just make a backup and then prune your other node so it won’t be 250GB..
    – Mike D
    Jan 18 at 22:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.