1

Linux Mint. Bitcoin Core 0.21.0.

I go to "File" and "Backup wallet", then select any location. I've tried with /home/a and /tmp and others.

Every time, Bitcoin Core says that the file has been successfully saved to the location I picked.

Then I look at that location in the GUI file manager, as well as in the terminal. THE WALLET .DAT BACKUP FILES ARE JUST NOT THERE!

I swear I'm not making this up and that I've enabled "Show hidden files" and tried everything to make sure that I'm not doing something wrong.

The files just are not saved, even though Bitcoin Core claims that they are. Why?

They are just not there on my file system. The only wallet.dat that exists is the actual one that Bitcoin Core itself saved, and it has put that in: /home/a/.var/app/org.bitcoincore.bitcoin-qt/data/blablabla/wallet.dat

At this point, having tried and asked and searched so much, I'm starting to truly question my sanity as well as the QA of Linux/Bitcoin Core.

This is even worse than various file nonsense in Windows. Is there some secret, very well hidden setting that I need to enable to "actually show the files" or something? Beyond "Show hidden files"?

11
  • Are you sure it is asking for a folder name and not a file name? (e.g. try entering "/tmp/backup-wallet.dat") Jan 20 at 11:08
  • @RedGrittyBrick Yeah, but even so, I tried again after you asked. Same thing. Bitcoin Core says it was saved to /home/a/test.dat, and then I go to that location, and there is just no test.dat. And what's worse, if I then do "File", "Back up wallet" again, Bitcoin Core's file GUI box does show my test.dat in that dir...
    – Willas
    Jan 20 at 11:17
  • I think I would check that SELinux is not installed and su to root in a terminal to ls -la /home/a and maybe also check the directory size. Sounds pretty weird. Jan 20 at 12:18
  • @RedGrittyBrick Unless "SELinux" is installed by default, it is not installed. And "su" just says "Authentication failed" every time it asks for the password. AFAIK, there was only one account set up in the installer, and that was the "a" user. No special "root" setup. I assumed that "a" is root.
    – Willas
    Jan 20 at 12:30
  • In the "users" section, there is only an "a" account and it's of type "Administrator".
    – Willas
    Jan 20 at 12:32
0

What possible explanation could there be that Bitcoin Core on Linux Mint claims to but does not save the wallet backups?

Possible explanations include:

  • The path to the saved file is not what you think it is
  • Some higher level of security is preventing you seeing the files
  • There is a bug in Bitcoin core. This seems unlikely but if you can reproduce the behaviour on another machine you could document the exact circumstances in a bug report.

footnote 1

All normal Linux systems have a large number of default users and not just the one you use to log in normally. If you cat /etc/passwd you'll see a list. It will include a root user (and around a dozen others) unless the system has been substantially modified from the typical arrangement.


footnote 2

You can make your own backups of the wallet.dat but, for extra reassurance, you could practice extracting the private key using the debug-console then importing the data into a new wallet (of any type) on another computer and verifying that you can create spending transactions there.

7
  • Well, it is definitely not a relative path. It has "/home" in the leftmost part, and the file is nowhere on my file system according to the find commands. As for chroot, I buy that it's a possible explanation, but I don't know how I would find out or what that means exactly. SELinux has not been installed by me, and AFAIK, Linux Mint doesn't do that on its own. But if so, why does that hide my files? The only other computer I have is this Windows one. Saving backup wallet.dats works perfectly well here with the same version as on the Linux Mint machine.
    – Willas
    Jan 20 at 13:28
  • And I don't know what to tell you in regards to the root user. I did not do anything weird and just followed the installer's questions and input fields.
    – Willas
    Jan 20 at 13:28
  • Let's say that this Bitcoin Core on Linux Mint is in some kind of "pretend-filesystem" inside of the real one. Okay. How do I get files out from there? How do I access it?
    – Willas
    Jan 20 at 13:42
  • And why would they just randomly add such a thing with not ONE WORD letting me know about it? I've already spent forever on syncing the blockchain... Now I don't even know how I'm going to get my wallet out from this damn machine.
    – Willas
    Jan 20 at 13:42
  • Notwithstanding your problem, you should be able to get the wallet by accessing the file /home/a/.var/app/org.bitcoincore.bitcoin-qt/data/blablabla/wallet.dat as mentioned in your question. You should be able to save this file manually as a backup.
    – csknk
    Jan 20 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.