2

There is a rather good explainer on https://bitcoin.org/en/full-node#port-forwarding on how to do port forwarding for bitcoin core in order to allow incoming connections so as to support the network.

I have followed the instructions, set a fixed local IP for the Mac running bitcoin core and am now trying to configure the router for port forwarding.

Here I am facing the issue that I do not know what to write in the External host field. Please see attached screenshot. I am trying * since I do not know the IP of external host, but this does not seem to be allowed. The instruction on the above link does not include the detailed configuration that my router requires.

Could anyone please identify what I am filling in wrong in the attached screenshot and suggest how I can change this so that my full node can start allowing incoming transactions?

Many thanks for your time and support!

configuration of my router

3

External host is the IP of the host connecting to you. If you want to allow anyone to connect, you can just put 0.0.0.0.

1
  • Thank you very much @darosior for your answer. This helped me along, but unfortunately I am not yet fully there. The error message I get after having added 0.0.0.0 as you suggested is still: "Operation could not complete. Something wrong happened". I also tried all the different options to choose from under "Service" Some of the options are: DNS, FTP, FPT-DATA, HTTP, HTTPS, ICMP. None of them worked however. I also tried all options for "Protocol". Is there something I am missing to prepare for the port forwarding? I run bitcoin core on a Mac Mini with SSD drive. Jan 22 at 16:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.