I have Bitcoin on an old version on the Bitcoin app; more specifically Bitcoin.org version 0.3.22. I tried to transfer the Coins to a newer wallet, but they don't go through. has anyone had or worked around this issue before? Thank you!

  • You'll probably get better answers (or at least some) if you edit the question to give a few details: What exactly did you do? Were there any error messages? What did you see happening exactly? Feb 10 at 17:14
  • Does 0.3.22 have getrawtransaction?
    – MCCCS
    Feb 10 at 19:29
  • I would strongly advise you to make a backup of the wallet.dat file, and then upgrade to a recent version of Bitcoin Core instead. 0.3.22 is extremely outdated, and unlikely to be able to catch up with the network (or even construct transactions the network accepts). Feb 12 at 4:01

You can use pywallet to import the wallet.dat and export the private keys.

Then you can just sweep them into electrum or any other wallet supporting WIF.

Pywallet can be downloaded here: https://github.com/jackjack-jj/pywallet

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.