0

I have retrieved an old wallet.dat file from my harddrive that crashed about 5 years ago.

I have downloaded the new version of bitcoincore and downloaded the blockchain. I have then copied the wallet.dat file (which is in 96 kb) into the directory where the wallet should be.

But when i try to open the wallet.dat i get this sign: "Warning: Skipping -wallet path that doesn't exist. Failed to load database path'E:\bitcoin\wallet1.dat'. Path does not exist.

It says E because i had to download the blockchain on a separate hdd.

What could the issue be? I have tried to make new wallets and open them from the same directory and that has not been a problem. Can i somehow open the wallet to retrieve the private keys??

1

tldr: specify a directory not a file and have that folder contain a wallet.dat not a wallet1.dat.


Your error message said

 Warning: Skipping -wallet path that doesn't exist. 
 Failed to load database path'E:\bitcoin\wallet1.dat'. Path does not exist.

However the help for the program says

-wallet=<path> Specify wallet path to load at startup. Can be used multiple times to load multiple wallets. Path is to a directory containing wallet data and log files. If the path is not absolute, it is interpreted relative to <walletdir>. This only loads existing wallets and does not create new ones. For backwards compatibility this also accepts names of existing top-level data files in <walletdir>.

(My emphasis).

An example configuration file says

# Specify where to find wallet, lockfile and logs. If not present, those files 
# will be created as new.
# wallet=</path/to/dir>

Your E:\bitcoin\wallet1.dat is a file not a directory

I can reproduce something similar by copying a valid wallet.dat to wallet1.data in a separate folder with no other Bitcoin files in it

C:> bitcoin-qt -wallet=c:\Users\ZZZ\Documents\wallet1.dat

Error message

So I think you could

  • rename wallet1.dat to wallet.dat
  • specify E:\bitcoin\ not E:\bitcoin\wallet1.dat.
1
  • Thank you. That is somehow confusing since the wallet.dat file in the is not named ”wallet1.dat”. After this message, btq opens without a wallet. What is more confusing is that the other wallet.dat filés are able to open in a way this particular one does not. The wallet.dat is in a folder with bitcoin files in it, and the other wallets do open when i run then from the same path. Now what could i do to retrieve the private keys? – Dogo777 Feb 27 at 14:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.