0

Trying to install and run Bitcoin Core Daemon on a Raspberry Pi 4 8GB w/ Ubuntu Server and unable to execute bitcoind.

Below are the exact steps I am taking:

  1. Use Raspberry Pi imager to flash the Ubuntu Server image to an SD card: Ubuntu Server 20.04.2 LTS (RPi 3/4/400) 64-bit server OS with long-term support for arm64 architectures

  2. Insert the SD card, turn on the Raspberry Pi, SSH in.

Run the following commands:

sudo apt update
sudo apt upgrade
sudo reboot
# Download bitcoin core: 
curl -O https://bitcoin.org/bin/bitcoin-core-0.21.0/bitcoin-0.21.0-arm-linux-gnueabihf.tar.gz
# Unzip
tar xzf bitcoin-0.21.0-arm-linux-gnueabihf.tar.gz
#Install
sudo install -m 0755 -o root -g root -t /usr/local/bin bitcoin-0.21.0/bin/*

When running the following I get the message (bash: /usr/local/bin/bitcoind: No such file or directory):

bitcoind --help

I have attempted to cd to /usr/local/bin and run

bitcoind --help

Still no luck

1

Edit: you’re using the wrong architecture bitcoind binary, gnueabihf means armv7 hard float, which is 32-bit. There are 3 possibilities:

  1. Download the correct Bitcoin binary for arm64 architecture (preferred);
  2. Use 32-bit OS;
  3. Install 32-bit compatibility layer on 64-bit OS.

Type ldd /usr/local/bin/bitcoind to check what libraries you’re missing. Most likely the only thing you need to do is to update your /etc/ld.so.cache by executing ldconfig.

ps: if you want to run a binary from the current directory, e.g. after switching to /usr/local/bin, you should type ./bitcoind, not just bitcoind.

4
  • I had a feeling it was something like this after all of the research I have been doing. Is there a problem with the Bitcoin download page? bitcoin.org/en/download. The one I am downloading is ARM Linux 64 bit - 32 bit (Maybe this isn't a good match for Ubuntu Server 64bit on RaspPi?). When running ldd I get "not a dynamic executable". Switching to /usr/local/bin and running ./bitcoind still gives the following message: -bash: ./bitcoind: No such file or directory. I do believe this is an architecture mismatch problem, or I do not have a required library. – Blake Rivell Mar 2 at 15:34
  • 2
    The correct link is bitcoin.org/bin/bitcoin-core-0.21.0/… - aarch64 is the name of the architecture that you need. You’ll see the same in the output of uname -a. – leshik Mar 3 at 13:56
  • Going to mark this as the correct answer if you want to update the description. Thank you so much! They should definitely put that option in the list on the main page. It is kind of hidden in the downloads directory only. – Blake Rivell Mar 4 at 7:10
  • Just wanted to say thanks for that, tried installing the ARM version showing on the bitcoin.org website but it didn't work. But going directly to their download directory I found this other version, thanks! Running bitcoind on Ubuntu 20.10 on a Raspberry Pie with 1TB Sata M2 drive attached via USB3. – Tom Apr 24 at 2:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.