0

I have setup multiple pools in the past for different Algo using NOMP, UNOMP, MPOS, YIIMP, etc open source solution. But it is first time I am setting a pool for Bitcoin - Tried UNOMP, NOMP, and NiceNOMP already. Mining works perfectly fine. Blocks are found, submitted, and balance is also visible in the node.

However, the payouts doesn't work. On checking the logs, I see an error

Daemon does not own pool address - payment processing can not be done with this daemon, {"isvalid":true,"address":"<wallet-address","scriptPubKey":"<script-publickey>","isscript":false,"iswitness":false}

I have triple checked wallet address with.

bitcoin-cli getaddressesbylabel ""

It belongs to the node. Just to be 100% sure, I also tried

bitcoin-cli dumpprivkey <wallet-address>

I did receive the private key for the wallet address specified. Further, I also updated the conf file to use legacy address only:

 addresstype=legacy

Node and pool are hosted on the same server connecting through 127.0.0.1

Below is the config file removing the obvious security details:

rpcuser=
rpcpassword=
txindex=1
server=1
addresstype=legacy
fallbackfee=0.00001
1

To all the future folks coming to this page from Google. The solution is simple.

The solution is for UNOMP, but it should be same for other pools as well.

Open:

paymentProcessors.js 

go to line 84 and change

isMine to isValid

restart the pool and payment processor will load without error. I just realized that validateAddress response has changed but pool libs are not updated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.