1

So here's the thing. I have an old Bitcoin Wallet backup from 2015 that I'm trying to restore. However when I try to import it back into the android application, even though I'm 99.9%** sure I got the correct passphrase, it is unable to import the wallet into the application. I tried following this tutorial to recover the private key, and after executing openssl enc -d -aes-256-cbc -md md5 -a -in bitcoin-wallet-backup-2015-12-22 > bitcoin-wallet-decrypted-backup with no error**, I get a decrypted file full of garbage. The next command in the tutorial is supposed to determine if the file is encoded in the protobuf or legacy base58 format, but it is neither of those, being instead binary gibberish.

I checked the encrypted backup and the padding is intact, which makes me think that the file is not corrupted? A lot of other people on the Internet seem to have the same issue, maybe someone here will be able to help me out.

Regards,

RK

** I'm 99.9% sure I got the correct passphrase because in both Bitcoin Wallet and openssl cli I don't get an "wrong password/bad decrypt" error when I use it, but when I input any other passphrase I get a "wrong password/bad decrypt" error. Sure, I could have the wrong passphrase but still get a false positive decrypt, but it seems pretty unlikely that I'm remembering a passphrase that is wrong and coincidentally outputs a false positive decrypt.

1
  • which version of the Android app did you try? They have changed how the wallet encryption work.so older backups will not import correctly with latest android version – KeychainX Mar 27 at 4:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.