I´m trying to install Bitcoin from source on an Apple M1 Mac Mini (Big Sur 11.2.3) and Im getting this when running

./configure --prefix=$PWD/depends/arm-apple-darwin20.3.0

"We could not detect the boost libraries (version 1.58.0 or higher). If you have a staged boost library (still not installed) please specify $BOOST_ROOT in your environment and do not give a PATH to --with-boost option."

config.log tells me:

configure:32586: checking for boostlib >= 1.58.0 (105800)
configure:32618: g++ -std=c++17 -c -g -O2 -I/opt/homebrew/opt/libffi/include -DHAVE_BUILD_INFO -D__STDC_FORMAT_MACROS -DMAC_OSX -DOBJC_OLD_DISPATCH_PROTOTYPES=0 -DPROVIDE_FUZZ_MAIN_FUNCTION  conftest.cpp >&5
conftest.cpp:73:10: fatal error: 'boost/version.hpp' file not found
#include <boost/version.hpp>
1 error generated.
configure:32618: $? = 1

I have boost installed via homebrew in /opt/homebrew/Cellar/boost (Version 1.75.0) and I did try

export BOOST_ROOT=/opt/homebrew/Cellar/boost

before building, but keep getting the same result.

echo 'export PATH="/opt/homebrew/opt/icu4c/bin:$PATH"' >> ~/.zshrc
echo 'export PATH="/opt/homebrew/opt/icu4c/sbin:$PATH"' >> ~/.zshrc
export LDFLAGS="-L/opt/homebrew/opt/icu4c/lib"
export CPPFLAGS="-I/opt/homebrew/opt/icu4c/include"

also didnt help. Any ideas very much appreciated. Thanks

2 Answers 2


Problem solved. Rosetta 2 was missing on the new system I set up. If anyone else runs into the same problem:

softwareupdate --install-rosetta

does the trick. Thanks to @AlgorithmicRisk on Twitter for pointing this out.


I had the same issue and it turns out that my system was missing the Boost library.

Install it using this(on wsl): sudo apt-get install libboost-all-dev Then it should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.