1

I am starting a LiteCoin mmcFE-pushpool pool for several clubs at my university, and am having some problem. First, we are running on an EC2 instance (Ubuntu), and have mmcFE and pushpull running. I am having two major issues before we can start up this pool...

1) On the web interface, users are able to create and account and log in just fine. On the left hand side, there is an error/notice that states: Notice: Undefined variable: totalOverallShares in /var/www/includes/leftsidebar.php on line 64 I am also getting Notice: Undefined variable: totalOverallShares in /var/www/includes/leftsidebar.php on line 71

2) Second, I went ahead and ignored the previous error and decided to run a CPU miner just to test the stats. Normally I can hash out (scrypt) at about 11kh/s on other peoples pools. It has been running for about 5hrs now, and my stats on the website are still saying 0. The cron job is running every 2 minutes. Using MINERD and never getting any "shares submitted, Yeah!" on my pc....

Does anyone have any pointers? I am really stumped as to what could be holding us up. You can see this problem on the webpage at http://p2pool.us

{
# network ports
"listen" : [
        # binary protocol (default), port 8336
        { "port" : 8336 },

        # HTTP JSON-RPC protocol, port 8337
        { "port" : 8337, "protocol" : "http-json" }

],

# database settings
"database" : {
       "engine" : "mysql",

       # 'host' defaults to localhost, if not specified
        "host" : "127.0.0.1",

       # 'port' uses proper default port for the DB engine,
       # if not specified
       "port" : "3306",

       "name" : "sc",
       "username" : "myusername",
       "password" : "mypasswd",
       "sharelog" : true,
       "stmt.pwdb":"SELECT password FROM pool_worker WHERE username = ?",

       "stmt.sharelog":"INSERT INTO shares (rem_host, username,   our_result,               upstream_result, reason, solution) VALUES (?, ?, ?, $
},

# cache settings
"memcached" : {
        "servers" : [
                { "host" : "127.0.0.1", "port" : 11211 }
        ]
},
        "servers" : [
                { "host" : "127.0.0.1", "port" : 11211 }
        ]
},

"pid" : "/tmp/pushpoold.pid",

# overrides local hostname detection
"forcehost" : "localhost.localdomain",

"log.requests" : "/tmp/request.log",
"log.shares" : "/tmp/shares.log",

# the server assumes longpolling (w/ SIGUSR1 called for each blk)
"longpoll.disable" : false,

# length of time to cache username/password credentials, in seconds
"auth.cred_cache.expire" : 75,

# RPC settings
"rpc.url" : "http://127.0.0.1:9332/",
"rpc.user" : "user",
"rpc.pass" : "pass",

# rewrite returned 'target' to difficulty-1?
"rpc.target.rewrite" : true,

# allow clients to update the ntime field of their work
"roll.ntime.disable" : false
}

The above shows my PUSHPOOLD config. Below, is my litecoind conf:

server=1
rpcallowip=127.0.0.1
rpcuser=user
rpcpassword=pass
  • I have the same problem. I've set the rpc.target.bits in server.json but I am unable to get any accepted shares. What am I missing? – Tristan May 16 '13 at 17:00
2

To answer your questions:

  1. This error is common, and i usually fixed after the first cronjob / first submitted share.

  2. This error is also common, as you have not set a difficulty in the server.json file. See this line here?

    #rewrite returned 'target' to difficulty-1? "rpc.target.rewrite" : true,

This tells the pushpoold that, if there's no difficulty set, then set it to -1, which is infinite, meaning you will NEVER find a share.

Add parameter

"rpc.target.bits" : 17

To the RPC setting section of server.json. You can change the value however you like. The higher it is, the more frequently you'll find a share. The lower it is, the hard it is to find one. This doesn't impact the ammount of LTC found.

If you're using mmcFE, be sure to edit that value in the configuration file of mmcFE.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.