2

I would like to do some solo mining of litecoin on OSX. I realize the probability is low that i will hit it. but i like the idea of the lottery. I have a miner setup (cgminer) and i have successfully connected to a pool. I have found lots of guides that explain how to do this on Windows like: https://bitcointalk.org/index.php?PHPSESSID=3rq912e407g04cjq8ehdhnk457&topic=83371.0

But what all these guides tell you to do is edit litecoin.conf and then restart litecoin-qt. But does this still apply to OSX? I don't see a litecoin.conf anywhere. I have looked in Library/Application Support/Litecoin Is it still litecoin.conf in OSX? or is it a different file?

2

~/Library/Application Support/Litecoin is exactly where your litecoin.conf has to go. Just go ahead and create it.

Good Luck with the Lottery!

  • So, i have added that file, and restarted litecoin-qt. But when i launch bfgminer with the settings: bfgminer --scrypt -o http://127.0.0.1:9332 -u username -p password -w 64 -I 13 it just hangs and displays an empty terminal. – deweydb May 6 '13 at 12:23
  • Oh, I'm dumb, i had a # in my password. So it works now. One more small question. How does litecoin-qt know which public key to credit when winning the lottery (say i have a couple public keys). – deweydb May 6 '13 at 12:25
  • Also, when it starts i see [2013-05-06 14:31:39] Probing for an alive pool [2013-05-06 14:31:39] Network difficulty changed to 396 (2.839Gh/s) [2013-05-06 14:31:39] No suitable long-poll found for http://127.0.0.1:9332 Does this mean i have not set it up correctly? – deweydb May 6 '13 at 12:35
3

No suitable long-poll found means that your bfgminer could not find a server that will inform it of a new block appearing on the network. This is correct, since you are solo mining, and litecoin-qt doesn't supply this.

Don't worry, your setup is correct.

Not having LP only means that your miner will get informed a little bit slower by litecoin-qt about a new block a little later, and potentially doing work on a block that has just been solved for a few seconds at most.

  • Thank you! I just ran bfgminer for a couple hours but it is still displaying 0Kh/s. When i have used bfgminer in pools in the past it would always display a non-zero rate for kH/s. Is this an indication that something is wrong? or is there no kH/s reporting when solo mining? – deweydb May 6 '13 at 20:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.