4

I'd like to upgrade from 0.21.0 to 0.21.1 on Mac Mini (Big Sur 11.1), compiling from source. When trying to compile the dependencies by running 'make' in /depends subdirectory, I get the following error:

ERROR: Feature 'system-zlib' was enabled, but the pre-condition 'libs.zlib' failed. make: *** [/Users/xxx/bitcoin/depends/work/build/arm-apple-darwin20.2.0/qt/5.9.8-82a1b93ac0c/qtbase/.stamp_configured] Error 3

Any advice on how to solve this would be appreciated!

2
  • 1
    Core doesn't yet support building on M1, see this PR github.com/bitcoin/bitcoin/issues/20371. Not many testers with M1 hardware it appears so please do comment on the PR and help with testing :) May 21, 2021 at 10:15
  • Thanks for the link; I'll hop over to github, will be happy to contribute testing! Oddly enough, I was able to build 0.21.0 (or a few commits afterwards), though boost and qt were some issues initially.
    – DataSci
    May 21, 2021 at 10:44

1 Answer 1

2

I ran into the same problem on tag v0.21.1 on my M1 macbook pro (Big Sur 11.4).

It turned out that i COULD "make /depends" on master. Then, however, even on master currently, "./configure --prefix=$(pwd)/depends/aarch64-apple-darwin20.5.0" won't finish successfuly (it can't find a specific QT lib).

To get v0.21.1 to compile on Apple silicon, I followed the build manual doc/build-osx.md. In particular, homebrew seems to provide all relevant dependencies apple silicon compiled as of now.

BUT, "./configure" as follows:

A "make -j 8" should then make Bob your uncle.

** cherry-picking the proper solution from https://github.com/bitcoin/bitcoin/pull/20603 didn't work for me due to merge conflicts

Regards,

Gebert

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.