I have a single password and a yubikey on my account at blockchain.info.

When I try to import the wallet.aes.json file nothing happens.

When I select the import file, MultiBit never displays the 'Number of Keys' or 'Replay date', so I put in my password and click "Unlock" then click "Import Private Keys".

The Bitcoin addresses in my account never show up on either in the send or request tabs.

I have also tried importing the unencrypted base58 json file from blockchain.info and it too has the same behavior (save entering my password).

Could you please point out how to export my wallet from blockchain.info to MultiBit?

1 Answer 1


Step one : Update your Multibit, normally since 0.3.4 it can import Blockchain.info https://groups.google.com/forum/?fromgroups=#!topic/bitcoin-multibit/G87Y3e1-0Ak

Anyway, if it's not working you can try this :

Go to Import/Export in Blockchain.info

Now "Export Unencrypted", change Base58 by Bitcoin-Qt format and take the key after "priv".

Now go to Multibit and EXPORT (yes export) your wallet WITHOUT password. Edit the file exported and you'll see several lines with ADDRESS (whitespace) DATE

Replace address with the blockchain's address. Change the date by the date you created the account (or a few time ago).

Now save and import this file in Multibit, et voilà !

  • I've tried running the import for blockchain.info format in multibit 0.5.9, which is why I'm so confused. I don't get any errors about incorrect formats, or inability to decrypt the file. I don't get any feedback at all.
    – akraut
    May 11, 2013 at 22:45
  • Strange indeed, but you can try the second option :) I don't know if it's exactly Base58 but you'll find that easily in the file exported.
    – Nontenda
    May 12, 2013 at 17:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.