1

I use Bitcoin-Qt. Decided to make another wallet and transfer some bitcoins there. Wanted to give that wallet to my friend as a gift. What I did was:

  1. renamed wallet.dat file to 1_wallet.dat
  2. started Bitcoin-Qt it created new wallet.dat file
  3. copied address of new wallet
  4. renamed wallet.dat to 2_wallet.dat and 1_wallet.dat back to wallet.dat
  5. transferred some bitcoins to new wallet address

finally after transaction was confirmed I still didn't see bitcoins in a new wallet. What I did wrong? Is it possible to get back these bitcoins?

  • 3
    Have you tried starting bitcoin with the -rescan command line option? – cdecker May 16 '13 at 7:52
  • cdecker should probably post that as an answer, that's my best guess too. If it was confirmed, it is irrevocably in that second address. – David Ogren May 16 '13 at 13:58
  • And just to make sure, ... your client is in sync as well? – Stephen Gornick May 16 '13 at 18:04
0

Removing all block chain and retrieving it again solved this problem. I guess -rescan should help too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.