0

I have noticed that Gloria's recent mail was doubly wrapped, which makes it harder to read:

I'm writing to propose a set of mempool policy changes to enable package
validation (in preparation for package relay) in Bitcoin Core. These would
not
be consensus or P2P protocol changes. However, since mempool policy

Note how the "not" appears on its own line.

How can this re-wrapping be avoided?

I have attempted to discovered the effective textwidth setting. I am using Neovim Nightly and I have no textwidth set, and if I use gq on that block, it puts the "not" on the previous line. It seems like Neovim wraps at 80 columns, and I suspect that Gloria's mail client does the same. Another custom setting must be necessary with Neovim.

As far as I know, 80 characters is a typical screen width used since the punch card era. But it seems like GNU Mailman, which generates the archive applies a smaller width. The largest textwidth setting I have discovered that puts the "not" on the next line is 77.

How can I configure Neovim to avoid having the archive re-wrap my mails? And how can I verify that my mails will not be mangled for any arbitrary Mailman installation?

1
  • This isn't really a problem with Bitcoin itself. This is a word-wrapping issue with pipermail. It would be best to ask in pipermail's support forums, or maybe in superuser.com. Sep 20 '21 at 9:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.