0

The build-windows.md says: "Additional WSL Note: WSL support for launching Win32 applications results in Autoconf configure scripts being able to execute Windows Portable Executable files. This can cause unexpected behaviour during the build, such as Win32 error dialogs for missing libraries. The recommended approach is to temporarily disable WSL support for Win32 applications."

How should I temporarily disable it? Is it done in the Ubuntu WSL shell, or in my local Windows machine?

1 Answer 1

2

Disable WSL support for Win32 applications:

sudo bash -c "echo 0 > /proc/sys/fs/binfmt_misc/status"

Enable WSL support for Win32 applications:

sudo bash -c "echo 1 > /proc/sys/fs/binfmt_misc/status"

https://github.com/bitcoin/bitcoin/blob/master/doc/build-windows.md#building-for-64-bit-windows

Is it done in the Ubuntu WSL shell, or in my local Windows machine?

Ubuntu WSL shell

1
  • Right. The title says "Build using:" and I expected the command to be before that, so I missed the comment in the script. Thanks. Sep 26, 2021 at 2:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.