0

I'm trying to run cpuminer on my Mac, though cpuminer requires a lot of command line tools - such as curl, libidn, etc. What are all of the tools required, and what is the minimum version of each I must obtain (e.g. curl 6)?

0

Compiled it on Linux. These are the dependencies once compiled :

$ readelf -d minerd

Dynamic section at offset 0x1c178 contains 22 entries:
  Tag        Type                         Name/Value
 0x0000000000000001 (NEEDED)             Shared library: [libcurl.so.4]
 0x0000000000000001 (NEEDED)             Shared library: [libpthread.so.0]
 0x0000000000000001 (NEEDED)             Shared library: [libc.so.6]
...

That's only libcurl and glibc. Since glibc is just a standard C library, and Mac probably has its own equivalent, you can ignore that one. The only runtime requirement is libcurl.

Judging by the source code the minimum required version of libcurl is 7.10.1. You'll also need yasm for 64-bit SSE2 code generation. And of course a C compiler that can handle C99.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.