3
  1. Every time I start Wasabi Wallet, it spends a least one hour downloading filters. Is this normal?

  2. When I start Wasabi Wallet (having first started Tor), my previously saved wallet does not appear in the Wallet Explorer. Is this normal?

The only way I can open my wallet is using "Recover Wallet".

This behaviour does not seem right to me. The documentation does not cover these questions. Can anyone throw any light on this please?

1
  • It sounds as if your wallet doesn't have persistent storage. Are you running the wallet from an ephemeral operating system like Tails?
    – Murch
    Oct 26, 2021 at 17:37

1 Answer 1

1
  1. It's not supposed to be. When starting Wasabi for the first time, Wasabi does have a longer 'downloading filters'. If you're using Wasabi frequently, it shouldn't take that long. Have you changed any settings? Maybe try to switch back to the defaults and see if it works better. Or you could turn of tor and see if that might be a problem (please consider privacy risks before switching off tor)

  2. No, that is not normal. If I understand correct: your wallet is also not displayed (using GUI) at 'wallet manager' -> 'Load Wallet'? If not, is your wallet displayed in the 'wallet folder'? See wallet folder: (top left corner) 'File' -> 'Open' -> 'Wallets Folder' ?

5
  • Hi, Thanks for your response. It spends a long time downloading filters every time I restart the application. I can't find the wallet files either. Cound this be a problem with permissions?
    – Robin
    Oct 26, 2021 at 16:51
  • The wallet is not displayed under 'load wallet', and nothing happens when I try to open the wallet folder.
    – Robin
    Oct 26, 2021 at 16:57
  • I didn't mention, I thought you'd know it you're using it: Lucas put it this way 'it could be that you're using a mem disk or one of those privacy oriented OSes that create temporary disks and then delete everything? That's why it has to re-download all the filters and recover the wallet from seed and do a full rescan.' Could that be the reason?
    – Marnix
    Oct 26, 2021 at 17:52
  • Thanks for your help. I'm using Linux Mint, which I have been using for many years without this kind of problem, although I have occasionally had problems with permissions. The folder /Home/.walletwasabi does not appear to have been created.
    – Robin
    Oct 26, 2021 at 18:24
  • Hmm ok, sounds like the reason why is your OS. Maybe this helps? forums.linuxmint.com/viewtopic.php?t=151399 if not, please let us know
    – Marnix
    Oct 27, 2021 at 7:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.