1

I have bitcoin core running. I installed it through bitcoin.org and installed via a dwg file. I want to use bitcoin-cli commands through my mac's terminal app. (not with bitcoin core's terminal). I tried cd into bitcoin core's file(which is in ssd because the lack of available space) and tried bitcoin-cli but it didn't work. Is there a way to talk to my bitcoin node through terminal (not with bitcoind)

Basically, I want to do bitcoin-cli operations from my mac terminal after running bitcoin-core

enter image description here enter image description here

3
  • This appears to be a dependency problem. It may be solved by upgrading to 22.0. Jan 16 at 15:17
  • I upgraded but it didnt solve the problem. Isn't there a way to speak to bitcoin-qt from operating system's terminal but not bitcoin-qt's console?
    – Efe Cini
    Jan 16 at 18:15
  • Sure, it's just JSON-RPC, there are frameworks in most programming languages that speak that. But this is a bizarre result. Bitcoin Core doesn't use openssl anymore, so I don't see why it is depending on it. Is there any chance you have an old bitcoin-cli, and it's using that? Jan 16 at 18:21

1 Answer 1

1

Uninstalling and reinstalling openssl library (via homebrew) solved the problem somehow.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.