1

I installed bitcoind and trying to run lightningd through this guide: https://github.com/ElementsProject/lightning/blob/master/doc/INSTALL.md#to-build-on-macos.

I did everything it says. Bitcoin node is running, blokcs are up to date but when I do "./lightningd/lightningd", it throws a message: "SQLITE version mismatch: compiled 3036000, now 3032003".

How do I fix this and run a lightning node?

1 Answer 1

2

Since losing the database could lead to loss of funds, C-lightning is a bit conservative and will only accept to start against a SQLite runtime dependency of the same version it was compiled with.

To solve this issue, just recompile lightningd.

5
  • Can you tell me which step is this on the link? Because I might have just done that. Os is Macos. Link: github.com/ElementsProject/lightning/blob/master/doc/…
    – Efe
    Feb 8, 2022 at 17:12
  • Did you update your system in-between the time you compiled lightningd and the time you tried to run it? Feb 8, 2022 at 17:23
  • Yes I might have. I tried so many thing so I'm not sure.
    – Efe
    Feb 8, 2022 at 17:26
  • 1
    Then just re-compile lightningd as suggested in the answer.. Feb 8, 2022 at 17:27
  • I did recompile still the same :(
    – Efe
    Feb 10, 2022 at 21:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.