6

I started co-mining on Slush's pool successfully for about 48 hours, but from there on I haven't been able to connect to it again. It logs in the console this, no matter if I'm using a valid worker and password or not:

2013-05-26 12:55:19: Listener for "Default" started
2013-05-26 12:55:20: Listener for "Default": api2.bitcoin.cz:8332 26/05/2013 12:55:20, checking for stratum...
2013-05-26 12:55:20: Listener for "Default": api2.bitcoin.cz:8332 26/05/2013 12:55:20, started OpenCL miner on platform 0, device 0 (Turks)
2013-05-26 12:55:20: Listener for "Default": api2.bitcoin.cz:8332 26/05/2013 12:55:20, no response to getwork, using as stratum
2013-05-26 12:55:20: Listener for "Default": api2.bitcoin.cz:8332 26/05/2013 12:55:20,  No JSON object could be decoded
2013-05-26 12:55:30: Listener for "Default": api2.bitcoin.cz:8332 26/05/2013 12:55:30, Failed to subscribe
2013-05-26 12:55:32: Listener for "Default": api2.bitcoin.cz:8332 26/05/2013 12:55:32, IO errors - 1, tolerance 2
2013-05-26 12:55:33: Listener for "Default" shutting down

Of course, I've checked my connection, and I've started GUIMiner with administrator privileges. I'm using Windows 7.

12

The problem is that in GUIMiner, the URL for Slush's pool is:

api2.bitcoin.cz:8332

That address has been deprecated, and it falls back to the GetWork protocol. From Slush's Pool news:

10.03.2013
Default mining URL for Stratum is stratum.bitcoin.cz:3333. If you're still using api.bitcoin.cz, please fix your URL to prevent fallback to deprecated Getwork protocol.

In the GUIMiner interface, instead of choosing "Slush's Pool" from the dropdown menu, choose "other" and then enter

http://api.bitcoin.cz:8332

or

stratum.bitcoin.cz:3333

  • Nice, it worked! – j4nSolo May 26 '13 at 21:37
  • 2
    Thank you this was verry helpfull, stratum.bitcoin.cz:3333 worked for me. – user5544 Jun 13 '13 at 2:00
  • i had the exact same problem but following ur instructions didnt help me a bit. whats wrong? – user5567 Jun 14 '13 at 9:00
  • When I tried it with the CPU miner (not GPU), api.bitcoin.cz:8332 worked, but stratum.bitcoin.cz:3333 did not work. – Peter Mortensen Jan 5 '14 at 18:11
1

Use stratum.bitcoin.cz and port 3333 in GUIMiner, not like http://stratum.bitcoin.cz:3333 that was mensioned in another answer.

protected by Community Nov 19 '13 at 10:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.