0

I am running a full node on Ubuntu (20.04), Core version 22.0.0, which is fully synced up to around 72500 blocks at this time. I am wanting to completely index the full chain however this has not worked correctly since downloading the blockchain. I have txindex=1 set in my bitcoin.conf file and have completed -reindex and bitcoind -reindex-chainstate however I do not get a full index and can seen that in my /blocks/index folder that I only have about 50 .ldb files as opposed to the hundreds I would expect if the full indexing had occurred.

I can run all commands successfully in bitcoin-cli except for 'getrawtransaction' which only works on the range of blocks that have been correctly indexed. I have tried removing all files and restarting bitcoind -txindex=1 however it will only index from about block 45000 onwards. I have attempted a variety of solutions listed on here and other places but nothing has fixed this yet.

Is there a way to force a reindex to start from blk0 or can anyone advise what files I need to make sure are removed so that a full -reindex will start correctly?

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.