0

I have installed bitcoin-core on my digitalocean droplet and configured with the following bitcoin.conf :

datadir=/mnt/volume_name/Bitcoin
dbcache=1000
txindex=1
server=1
rpcuser=rpcuser
rpcpassword=rpcpassword
rpcport=8332

Then I start daemon, it begin to synchronize. Volume size is 500Gb, I thought it will be enought space for bitcoin blockchain, wich for now is around 414 Gb. But, after a few days I realized that the volume is full!

$ df -h

Filesystem      Size  Used Avail Use% Mounted on
--- // ---
/dev/sda        496G  471G  4.0K 100% /mnt/volume_name
--- // ---

At the moment it stoped working and obvious it cant start again. Why it continue to fill all space on the disk? I know it has to be some misconfiguration, but I don't understand what exectly is wrong.

3
  • I think blockchain is currently around 441G, not 414G...
    – Mercedes
    Jun 29 at 8:31
  • Use the du command to explore disk usage of your system.
    – Mercedes
    Jun 29 at 8:34
  • If you don't plan to use the transaction index, you can just purge it out in order to free some space.
    – Mercedes
    Jun 29 at 8:55

1 Answer 1

2

The transaction index, that you enabled, is sized at multiple GB (>10). Disable it, and then it's much more likely that it'll fit.

2
  • Okay, I'll try it. Thank you! Jun 29 at 8:39
  • 1
    @alex8327492 After you disable it, you can find and remove the transaction index files, that won't damage the rest of the datadir
    – Mercedes
    Jun 29 at 8:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.