1

When i try to install package on raspibitz I receive the annoying warnings regarding locale.

₿ sudo apt install apt-transport-https                                                                                                                                      
...                                                                                                                                                                         
apt-listchanges: Can't set locale; make sure $LC_* and $LANG are correct!                                                                                                                                          
perl: warning: Setting locale failed.                                                                                                                                                                              
perl: warning: Please check that your locale settings:                                                                                                                                                             
        LANGUAGE = (unset),                                                                                                                                                                                        
        LC_ALL = (unset),                                                                                                                                                                                          
        LC_TIME = "de_DE.UTF-8",                                                                                                                                                                                   
        LC_MONETARY = "de_DE.UTF-8",                                                                                                                                                                               
        LC_ADDRESS = "de_DE.UTF-8",                                                                                                                                                                                
        LC_TELEPHONE = "de_DE.UTF-8",                                                                                                                                                                              
        LC_NAME = "de_DE.UTF-8",                                                                                                                                                                                   
        LC_MEASUREMENT = "de_DE.UTF-8",                                                                                                                                                                            
        LC_IDENTIFICATION = "de_DE.UTF-8",                                                                                                                                                                         
        LC_NUMERIC = "de_DE.UTF-8",                                                                                                                                                                                
        LC_PAPER = "de_DE.UTF-8",                                                                                                                                                                                  
        LANG = "en_GB.UTF-8"                                                                                                                                                                                       
    are supported and installed on your system.                                                                                                                                                                    
perl: warning: Falling back to a fallback locale ("en_GB.UTF-8").                                                                                                                                                  
locale: Cannot set LC_ALL to default locale: No such file or directory                                                                                                                                             
...           

What can i do to fix that problem?

1 Answer 1

1

I run dpkg-reconfigure locales as root and selected additionally de_DE.UTF-8 to fix the problem.

Problem of Can't set locale; make sure $LC_* and $LANG are correct!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.