0

I have a bitcoin full node running on a raspberry pi 3b but it doesn't have enough memory to also run lnd at the same time so I'm trying to do that on a separate machine connected to the same network. I've read that this is possible but when I try to get it going I get this error:

error

It seems that the problem is when lnd tries to run getblockhash it can't talk to the machine running bitcoind. Any ideas how to make this work would be appreciated!

1 Answer 1

1

According to the logs, your lnd is trying to access the bitcoind RPC interface at the default http://localhost:8332, which only works if you have bitcoind running on the same machine. For a remote instance you will need to set the config option bitcoind.rpchost in your lnd.conf file to the IP address of the machine running bitcoind (see sample-lnd.conf). Additionally, if you haven't already, you will need to setup RPC authentication (options bitcoind.rpcuser and bitcoind.rpcpass).

1
  • This seems to have solved the error that was coming up so thank you, but now it just gets stuck at 2022-08-29 17:08:00.596 [INF] CHRE: Primary chain is set to: bitcoin and then eventually times out. Any more ideas?
    – gruntled
    Aug 29, 2022 at 11:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.