3

I am running Wasabi wallet on linux machine and would like to force it to use system tor service. Tor is being blocked by my ISP, but I have set up bridges for my system tor daemon, and it works OK. But Wasabi - does not.

It seems to me it starts it's own tor service and does not respects settings in system-wide /etc/tor/torrc config file.

Changing ISP or using VPN helps, but it is not the solution for me.

1 Answer 1

4

There are several important pieces of information mentioned here:

  • Wasabi Wallet 1 is distributed with a specific version of Tor binaries but WW1 actually works with any version of Tor running on given operating system[^1].
  • Wasabi Wallet 2 is distributed with Tor binaries (i.e. Tor is bundled) and we actually always run the distributed Tor with non-standard port setting to avoid using any non-bundled Tor versions.

So to explain it in simple terms: Wasabi Wallet 2 uses a bundled Tor because WW2 requires access to Tor control protocol and because it makes sure that the Tor version is reasonably up to date. So Wasabi Wallet 2 deliberately does not use system-wide Tor.

I can see potentially several ways how to fix your issue.

For people without programming skills:

  • Open $HOME/.walletwasabi/client/TorLogs.txt file in a text editor and you should see a line Configuration file "/var/tmp/dist/tor/etc/tor/torrc" not present, using reasonable defaults. So maybe you can just modify this torrc file as you need.

For people with programming skills:

1
  • 3
    Great! The solution with adding custom config helped. The file was not present in that directory (and the directory also did not exist), so i just added a link to system torrc file like this: ln -s /etc/tor/torrc. Works perfect
    – zetroot
    Oct 28, 2022 at 16:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.