1

Whenever I connect miners to pushpoold (connected to litecoind), it's not updating the shares table in MySQL (which in turn means the stats on mmcfe isn't updating). I'm pretty certain the database settings are correct as pushpool can read the users table to authenticate the miners and it's not an mmcfe config because I've inspected the shares table independently of mmcfe.

My pushpool server.json file is as follows:

{
    "listen" : [
            { "host": "domain.com", "port" : 8336 },
            { "host": "domain.com", "port" : 8337, "protocol" : "http-json" },

            # HTTP JSON-RPC protocol, port 8339,
            # with trusted proxy appserver.example.com forwarding
            # requests to us
            #{ "port" : 8337, "protocol" : "http-json",
            #  "proxy" : "appserver.example.com" },

            # binary protocol, localhost-only port 8338
            { "host" : "127.0.0.1", "port" : 8338, "protocol" : "binary" }

    ],

    "database" : {

            "engine" : "mysql",

            "host" : "localhost",

            "port" : 3306,

            "name" : "db",
            "username" : "user",
            "password" : "pass",

            "sharelog" : true,

            "stmt.pwdb" :
              "SELECT password FROM pool_worker WHERE username = ?",

            "stmt.sharelog" :
             "INSERT INTO shares (rem_host, username, our_result, upstream_result, reason, solution) VALUES (?, ?, ?, ?, ?, ?)"

    },

    "memcached" : {
            "servers" : [
                    { "host" : "127.0.0.1", "port" : 11211 }
            ]
    },

    "pid" : "/opt/pushpool/tmp/pushpoold.pid",

    "forcehost" : "localhost",

    "log.requests" : "/opt/pushpool/tmp/request.log",
    "log.shares" : "/opt/pushpool/tmp/shares.log",

    "longpoll.disable" : false,

    "auth.cred_cache.expire" : 75,

    "rpc.url" : "http://127.0.0.1:8332/",
    "rpc.user" : "user",
    "rpc.pass" : "pass",

    "rpc.target.bits" : 21,

    "work.expire" : 120,

    "roll.ntime.disable" : false
}

I've already searched through stackexchange as well as the wider web, so I think I've picked up on all the basic mistakes (eg not including stmt.sharelog and the rpc.target.bits), but I suspect this is still a configuration problem and that I've overlooked something really stupid.

Overview specs:

  • What happens when you run stmt.sharelog manually, putting in test values for the ? marks? – Nick ODell Jun 10 '13 at 22:58
  • Same thing. No data inserted into the db and no error outputted to the logs. – laumars Jun 11 '13 at 20:57
0

First of all I thought that you were using a bitcoin pushpool as your primary software for a litecoin pool. But I guess you've checked that? Otherwise, try this recomended pushpool fork instead, which worked for me: (For LTC) https://github.com/ArtForz/pushpool

This one works for me, but ideally you would want to use the stratum software for mining purpose. (If you have clients connecting with LP/Getwork, you can add the stratum-proxy locally on your server)

  • I thought pushpool was the same regardless of whether it's serving BTC or LTC? If that's not the case, how would I check? The connected litecoin miners do get handed jobs to crunch so I've assumed that the pushpoold->litecoind set was correct. But can't hurt to double check. re Stratum: I am planning to add Stratum once I've got pushpool working, but haven't got that far yet. Thanks for the recommendation there though. – laumars Jun 11 '13 at 20:43
  • Meant to add, I'll bare ArtForz fork in mind if this stackexchange question doesn't find the answer (to be honest, I'm starting to think it is just the fork I'm using - but I want to eliminate the other possibilities first). Thanks :) – laumars Jun 11 '13 at 20:57
  • @laumars I think that is your reason really. I was starting out with a different pushpool build and my workers were never submitting shares. I suspected something to be very wrong, and decided to follow a small guide instead (they used the ArtForz fork) and poof it worked. :) Can't tell you how or why – Robin Jonsson Jun 11 '13 at 23:02
  • update: that worked. – laumars Jun 12 '13 at 14:19
  • Good :) Happy that it got resolved! Me myself is also running a pool: litepool.in – Robin Jonsson Jun 12 '13 at 18:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.