1

I have Bitcoin Core 24.0.1 64bit on Windows 10 which is seemingly stuck on updating with the latest transactions. It seems also that I have port 8333 blocked (checked on https://canyouseeme.org/), but not sure if that's even relevant. I am receiving "outbound" traffic in the peers-view window. I tried chaging the port to 8332, 80 and other random ports in the bitcoin.conf file but to no avail. I also tried deleting the peers.dat file but also without any impact. This used to work last year, I would appreciate any info on how I can get this updated so I can transfer by BTC.

https://i.sstatic.net/jEztj.png

4
  • 1
    How long has it been like this? Commented Jan 31, 2023 at 17:29
  • 1
    Where did you download Bitcoin Core?
    – Murch
    Commented Jan 31, 2023 at 20:36
  • @PieterWuille - like this since November, like in the screenshot. I didn't notice until recently. I have the app open on WIndows startup
    – nan
    Commented Feb 5, 2023 at 12:41
  • @Murch I just updated to the newest version to see if that would help, I got the updated .exe file from bitcoincore.org
    – nan
    Commented Feb 5, 2023 at 12:42

3 Answers 3

1

Can you check to see if 8333 is being used by bitcoin core? Do a netstat -ab. Have you checked for adequate diskspace?

1
  • Thanks for the suggestion. Disk space is not an issue, the disk that Bitcoin core is writing to has over 120GB of free space left. Upon inspecting the netstat result, bitcoin-qt.exe is connecting to ports 80, 8334, 61472, 61473, 61474, 61475 initially but later it does establish connections to concrete IPs with ports 18333 and 8333
    – nan
    Commented Feb 5, 2023 at 13:00
0

I suggest publishing debug logs for inspection. Additionaly, there may any of the options fix an issue:

  • -reindex (rebuild chain state and block index from the blk*.dat files on disk)
  • -datadir=<dir> (specify another data directory),
  • -loadblock=<file> (Imports blocks from external file on startup).

There is the information invoked like this: .\bitcoin-qt.exe --help

0

An outbound-only node is more than enough to sync a node. No need to fiddle with that.

There are two steps to rebuild your chain. First, you need to sync with other nodes to get the latest header. Then, bitcoin-core reads all your local *.blk blocks and rebuilds its database.

You seem to be stuck at first stage and unable to sync with other nodes. I'd suggest to check on any firewalls or other network configuration that might block this process, as well as reverting to defaults on bitcoin-core, regarding network configuration.

You can have port 8333 closed (or any other inbound port for that matter) and won't have any issues while syncing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.