1

I am running Bitcoin core on a raspberry pi with an external ssd. I am using this line in the bitcoin.conf to move block storage onto the ssd: blocksdir=/media/bitcoinstorage/.bitcoin/blocks

However, when I run bitcoind, blocks still get written to the default location at ~/.bitcoin/blocks

This is what I've tried so far:

Running with these flags:

bitcoind -conf=path/to/conf -blockdir=/media/bitcoinstorage/.bitcoin/blocks

Precreating the .bitcoin/blocks directories in the desired location.

Setting permissions on both directories involved (media and bitcoinstorage) to 777 to no avail. The default permissions for using /media required sudo - I don't know much about how permissions work and if they're inherited so I'm guessing this might have something to do with it.

Each time in between I have deleted the .bitcoin directory entirely and done bitcoin-cli stop before trying again. It seems like no matter what I do I cannot change the default blocks storage location.

Any help would be appreciated here. Thanks :)

1 Answer 1

1

There is a typo in your flag. It reads blockdir but it should be blocksdir.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.