1

I am trying to make rpc calls to an Rpc Interface "listunspent". So i get this Error: ESOCKETTIMEDOUT. I checked the bitcoin node debug file and saw the error message "Depth queue work exceeded". I have added this option rpcworkqueue= settings to the bitcoin.conf file.

Here is my bitcoin.conf file

prune=550 port=8333 rpcworkqueue=1000 rpcuser=user rpcpassword=userpass zmqpubrawblock=tcp://127.0.0.1:29000 zmqpubrawtx=tcp://127.0.0.1:29000 zmqpubhashtx=tcp://127.0.0.1:29000 zmqpubhashblock=tcp://127.0.0.1:29000

The following is the error response i get while trying to make rpc calls from my node app

{
"status": 500,
"error": {
    "name": "RequestError",
    "message": "Error: ESOCKETTIMEDOUT",
    "cause": {
        "code": "ESOCKETTIMEDOUT",
        "connect": false
    },
    "error": {
        "code": "ESOCKETTIMEDOUT",
        "connect": false
    },
    "options": {
        "auth": {
            "user": "user",
            "pass": "userpass"
        },
        "uri": "/",
        "baseUrl": "http://127.0.0.1:8332",
        "timeout": 30,
        "json": true,
        "body": {
            "method": "listunspent",
            "params": {},
            "jsonrpc": 1,
            "id": "rpc-bitcoin"
        },
        "method": "POST",
        "simple": true,
        "resolveWithFullResponse": false,
        "transform2xxOnly": false
    }
}

}

Any help to solve this?

1 Answer 1

0

Something is trying to make too many simultaneous RPC requests.

Running parallel jobs making RPC requests, I've noticed that only 2 requests can be made simultaneously for certain things, and even then it occasionally threw error: Server response: Work queue depth exceeded.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.