9

I have created a conf file on the following path:

C:\Users\NAME\AppData\Roaming\Bitcoin\bitcoin.conf

When I run the Bitcoind file, nothing happens. My command line window becomes unresponsive as if it's waiting. I've waited ~1 hour, and my computer is pretty highend (i7 processor, 16gb ram).

enter image description here

I want to run the server and fire some commands on the bitcoind server.

I have the following conf file:

# bitcoin.conf configuration file. Lines beginning with # are comments.


 # Network-related settings:

 # Run on the test network instead of the real bitcoin network.
 #testnet=0

 # Connect via a socks4 proxy
 #proxy=127.0.0.1:9050

 ##############################################################
 ##            Quick Primer on addnode vs connect            ##
 ##  Let's say for instance you use addnode=4.2.2.4          ##
 ##  addnode will connect you to and tell you about the      ##
 ##    nodes connected to 4.2.2.4.  In addition it will tell ##
 ##    the other nodes connected to it that you exist so     ##
 ##    they can connect to you.                              ##
 ##  connect will not do the above when you 'connect' to it. ##
 ##    It will *only* connect you to 4.2.2.4 and no one else.##
 ##                                                          ##
 ##  So if you're behind a firewall, or have other problems  ##
 ##  finding nodes, add some using 'addnode'.                ##
 ##                                                          ##
 ##  If you want to stay private, use 'connect' to only      ##
 ##  connect to "trusted" nodes.                             ##
 ##                                                          ##
 ##  If you run multiple nodes on a LAN, there's no need for ##
 ##  all of them to open lots of connections.  Instead       ##
 ##  'connect' them all to one node that is port forwarded   ##
 ##  and has lots of connections.                            ##
 ##       Thanks goes to [Noodle] on Freenode.               ##
 ##############################################################

 # Use as many addnode= settings as you like to connect to specific peers
 #addnode=69.164.218.197
 #addnode=10.0.0.2:8333

 # ... or use as many connect= settings as you like to connect ONLY
 # to specific peers:
 #connect=69.164.218.197
 #connect=10.0.0.1:8333

 # Do not use Internet Relay Chat (irc.lfnet.org #bitcoin channel) to
 # find other peers.
 #noirc=0

 # Maximum number of inbound+outbound connections.
 #maxconnections=


 # JSON-RPC options (for controlling a running Bitcoin/bitcoind process)

  server=1 #tells Bitcoin-QT to accept JSON-RPC commands.
 #server=0

 # You must set rpcuser and rpcpassword to secure the JSON-RPC api
 rpcuser=USERNAME_IVE_CHOSEN
 rpcpassword=PASSWORD_IVE_CHOSEN

 # How many seconds bitcoin will wait for a complete RPC HTTP request.
 # after the HTTP connection is established. 
 #rpctimeout=30

 # By default, only RPC connections from localhost are allowed.  Specify
 # as many rpcallowip= settings as you like to allow connections from
 # other hosts (and you may use * as a wildcard character):
 #rpcallowip=10.1.1.34
 #rpcallowip=192.168.1.*

 # Listen for RPC connections on this TCP port:
 #rpcport=8332

 # You can use Bitcoin or bitcoind to send commands to Bitcoin/bitcoind
 # running on another host using this option:
 #rpcconnect=127.0.0.1

 # Use Secure Sockets Layer (also known as TLS or HTTPS) to communicate
 # with Bitcoin -server or bitcoind
 #rpcssl=1

 # OpenSSL settings used when rpcssl=1
 #rpcsslciphers=TLSv1+HIGH:!SSLv2:!aNULL:!eNULL:!AH:!3DES:@STRENGTH
 #rpcsslcertificatechainfile=server.cert
 #rpcsslprivatekeyfile=server.pem


 # Miscellaneous options

 # Set gen=1 to attempt to generate bitcoins
 #gen=0

 # Use SSE instructions to try to generate bitcoins faster.
 #4way=1

 # Pre-generate this many public/private key pairs, so wallet backups will be valid for
 # both prior transactions and several dozen future transactions.
 #keypool=100

 # Pay an optional transaction fee every time you send bitcoins.  Transactions with fees
 # are more likely than free transactions to be included in generated blocks, so may
 # be validated sooner.
 #paytxfee=0.00

 # Allow direct connections for the 'pay via IP address' feature.
 #allowreceivebyip=1

 # User interface options

 # Start Bitcoin minimized
 #min=1

 # Minimize to the system tray
 #minimizetotray=1

Any ideas how to make the server work?

  • 1
    What you could try is adding daemon=1 to the bitcoin.conf file and just run the bitcoind command without arguments. I have no experience with Windows command lines, if the executable file is in that folder but not in your default binary path, in Linux the command would be ./bitcoind -daemon, with the ./ meaning that you want to execute a file in that particular folder. – Steven Roose Jun 19 '13 at 22:36
5

As far as i know, you are running the bitcoind client as it should be run. You need to explicitly say that you want your bitcoind to be run as a daemon. try changing your server=1 configuration lines to this (your comment may have inadvertently messed with bitcoin... but i don't know that for any fact, just a hypothesis) here's your example modified

# JSON-RPC options (for controlling a running Bitcoin/bitcoind process)

# server=1 tells Bitcoin-QT to accept JSON-RPC commands.

server=1

Also, when in doubt run bitcoind in one cmd window and bring up a second one. Recurse in to the directory containing bitcoind (inside that second cmd window). Then try to run a simple command (try bitcoind getblockcount) if you get a result then you know bitcoind is working, but it is not starting as a background service.

If you are using the bitcoin-qt client, don't edit anything in the config file. Configure the Bitcoin client to start automatically.

" GUI-Settings: Settings -> Options then mark the checkbox titled: [X] Start Bitcoin on system startup " Source: https://en.bitcoin.it/wiki/Running_Bitcoin

Also, if your reason for using bitcoind over bitcoin-qt is due to the ability to pass text commands to bitcoin: the console is accessible from the Help menu (Help->Debug->console)

I am not going to claim i know everything, and im sure some of this is not perfect information, but i will update it and gladly work through issues with anyone i can help. Just be kind ;)

  • Thanks :) Yes it is running, but simply not in the background! – Lars Holdgaard Jun 21 '13 at 16:33
  • great! let me know if i can help you more :D – Joe White Jun 21 '13 at 22:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.