2

I run Bitcoin Core under Windows 10. I have now set up a Docker container to run Bitcoin Core under Linux on the Windows computer. I copied the Windows Bitcoin directory (containing all the blockchain data) to another directory and mapped the Docker container to it.

Launching the Docker container Bitcoin Core starts its initial download as if the data is not already there.

Can anyone think of any reason the Windows data would not be acceptable to the Docker/Linux app?

1 Answer 1

1

Doh! I had the mapping for the directory wrong in the docker file. It has now started up and is verifying the blocks.

I would delete the question, but knowing this works may be useful to someone.

1
  • FFS... I keep seeing my questions and answers edited for 'capitalisation' or should that be 'Capitalisation' -- I guess this is a way of people gaming the system to look good for their edits, while adding NOTHING of any value... I have found stack exchange useful in the past, and tried to add useful info, but it looks like it is past it - taken over by bad people (like wikipedia has been).
    – pperrin
    Oct 19, 2023 at 23:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.