I'm very new to Namecoin and tried to to register a domain with name_new d/<name>. I received the tx and rand response which seemed normal. Later (after 12+ blocks) when I did firstupdate and it responded with an error (using windows and I think I had escape issues):

error: {"code":-1,"message":"name_firstupdate <name> <rand> [<tx>] <value>\nPerf
orm a first update after a name_new reservation.\nNote that the first update wil
l go into a block 12 blocks after the name_new, at the soonest."}

So I corrected the escape issues and reissued firstupdate:

error: {"code":-1,"message":"this name is already active"}

And then thinking maybe the original firstupdate took, escape issues and all, I tried an update:

error: {"code":-1,"message":"this coin is not in your wallet"}

I then did what I should have done first and looked up the domain name and found it exists and will expire in 188 days.

So... my questions are:

1) Why did the name_new not inform me it was taken? The Wiki implies using name_new checks for existance:

Or check if your domain if free with the command line (the command line don't do the conversion) :

./namecoind name_new d/<name>

2) Does the .01 fee for name_new just disappear?


Maybe a little bit late, but for everybody who is interested, the easy command to check if a name exists is simply:

> ./namecoind name_show d/<name>

It will return some informations should the name already be registered, or it will return

error: {"code":-4,"message":"failed to read from name DB"}

if the name doesn't exist.


Just use namecoin-qt This does everything automatically.

  • This doesn't answer the question. – Nate Eldredge Sep 21 '13 at 21:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.