1

I successfully downloaded the Bitcoin blockchain on an external hard drive (as well as git repository). It was working and syncing just fine. I haven't used in a month or so, now the blockchain won't continue the download (starts download from beginning) even though I specified the datadir and blockdir. I tried the usual solutions such as setting the path of blocks and datadir (to the path in the external HDD). None of them work. I tried running the CLI and the GUI, same problem. It doesn't install it in the correct path.

Also, when it was reinstalling the whole blockchain, it puts the new blocks folder in the original blockdir (as a nested folder).

Am I missing a step?

Do I have to mount the HDD to the home directory? it is currently in /media

I am using Ubuntu 22.10

This is the datadir and blocksdir in bitcoin.conf file

datadir=/media/kibnakamoto/kntc/work/Bitcoin/
blocksdir=/media/kibnakamoto/kntc/work/Bitcoin/blocks/

I run the bitcoin-qt using the following command directory /media/kibnakamoto/kntc/work/Bitcoin/src/qt/bitcoin-qt -conf=/media/kibnakamoto/kntc/work/bitcoin.conf

This sets the datadir to /media/kibnakamoto/kntc/work/Bitcoin/blocks and blocksdir to /media/kibnakamoto/kntc/work/Bitcoin/blocks/blocks

(kntc is the HDD name)

I have tried only setting datadir instead of both blocksdir and datadir

3
  • Remove the transaction index from your bitcoind options and share drive format info. Have you tried setting only datadir (no blockdir)?
    – Mercedes
    Commented Apr 16, 2023 at 12:29
  • @Mercedes I updated my question with more data. Hope that helps! Commented Apr 16, 2023 at 12:56
  • You should share drive format info. You are using one same directory for data and source, that's uncommon, use a different directory for data and source, specially in case you don't understand Git. Don't specify blocksdir until a simpler configuration is working.
    – Mercedes
    Commented Apr 17, 2023 at 13:39

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.