6

I am creating a transaction with Bitcoin Core (v24.0.1) and it has RBF enabled (sequence: 4294967293) by default. I am trying to disable RBF by adding walletrbf=0 and mempoolfullrbf=0 to bitcoin.conf but it does not seem to make any difference to the input's sequence field.

EDIT: I use bitcoin-cli createrawtransaction to create the transaction.

1 Answer 1

9

walletrbf=0 only disables RBF when creating transactions through wallet RPCs such as sendtoaddress, sendmany or sendall. If you use the low-level RPC createrawtransaction, you need to either set the replaceable parameter to false or manually set your sequence numbers. If you're creating transactions through the Send tab in the GUI, you simply need to uncheck a checkbox right below fee selection that says "Enable Replace-By-Fee".

mempoolfullrbf=0 controls a mempool policy (whether to allow replacements for transactions that don't signal RBF), it has nothing to do with the wallet, and it's currently off by default which means this line in bitcoin.conf isn't actually doing anything.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.