I setup p2pool on my ubuntu 12.04LTS x64 machine. Installed cgminer 3.3 and ran it. the newest cgminer is supposed to support the USB mode with the erupters without any extra configuration.

I have 2 erupters on a powered usb2 hub and 2 running off the motherboard direct. The hashing is just not stable; jumping from 50mh to 300, then getting sick and restarting- there are a ton of rejects. The avg on 4 should be 1.2gh but I am hardy getting 300mh.

I don't know what is wrong. I have been reading many posts all over over the place, one after the other and I am stumped. It is not meant to be this difficult- is it??

What did I miss?

enter image description here

  • what kind of heat are they giving off? have you tried apublic pool to see if it is your p2pool installation? let me know, i'll try to walk you through it...
    – Joe White
    Commented Jun 25, 2013 at 14:16
  • The are warm/hot - I know they should get as hot as not able to touch them for too long. But they get about 45/50degrees but all 4 have various temperatures. Can you suggest a public pool please (i know i can google but if you know 1 that works 100% then let me try it) I tried installing bfgminer now but that does not even detect them.. :(
    – Piotr Kula
    Commented Jun 25, 2013 at 14:23
  • Whoa.. I think I got bfg miner to work properly. for some reason when I ran bfgminer the usb's disappeared in /dev/ttyUSB .. I had to reboot and they were back. I made sure that bitcoind loaded all blocks, ran my p2pool script then started bfgminer with -S all ... 350MH now!!! I don't understand.
    – Piotr Kula
    Commented Jun 25, 2013 at 14:33
  • 1
    i was just about to suggest BFGMiner, but decided to wait. glad it worked... The reason it works now is because BFGMiner is more up to date than CGMiner is.... BFGMiner gets constant updates by luke-jr where as cgminer is hit and miss. luke-jr spends a lot of time getting the latest drivers in place.
    – Joe White
    Commented Jun 25, 2013 at 17:36
  • Fantastic :) I thought cgminer was more up to date.. I learnt something new. Thanks for trying to help!
    – Piotr Kula
    Commented Jun 26, 2013 at 10:08

3 Answers 3


I am now using cgminer 3.4.2 (Ubuntu 12.04LTS) as it is much more stable than bfgminer and all the bugs in cgminer have been worked out (it also supports hot plugging)

The best way is to compile cgminer from git direct. There is some dependency on usbdev1 that needs to be compiled into cgminer.

  1. Install the dependencies using apt-get (including all the build stuff)
  2. Make a direcotry somewhere and go into it
  3. git clone git://github.com/ckolivas/cgminer.git
  4. cd into the cgminer directory
  5. ./autogen.sh --enable-bflsc --enable-icarus --disable-opencl
  6. CFLAGS="-O2 -Wall -march=native" ./configure --enable-bflsc --enable-icarus --disable- opencl
  7. make -j8
  8. Run cgminer from that directory, without any options. (except the mining pools you need) It will pick up on the erupters and is ready for BFL rigs too! Hot plugging works well also!

enter image description here

Its not running full speed because I have a slight power issue after adding 7 more. Need a new PSU


I had the same problem.

I solved it by spawning a cgminer for each erupter using --usb :1 to limit each miner to 1 device which gave me the performance back,

i.e. 1xcgminer mapped to 1 erupter will drive it at 350mh but add a 2nd or a 3rd and performance disappears.

I hadnt tried bfminer but I might as well now having seen your results

  • I have been running bfminer and it is much more stable than cgminer in my opinion (actually not a single crash in more than 15 days or constant mining). Not sure if its the erupters more stable. Before I had 6990's running on cgminer - i had to restart cgminer almost every day(luckily i had cgminerwatcher installed- so it did it for me)
    – Piotr Kula
    Commented Jul 19, 2013 at 9:11

just use cgminer 3.1.1 ... i'm using 4x asic usb miner's... it works fine... and i'm using it on powered hub and raspberry pi

  • 3.1.1 did not work for me on Ubuntu. I have 3.4.2 on Ubuntu now (had to compile it) but it works a charm. I liek the way you use your Raspberry Pi :)
    – Piotr Kula
    Commented Sep 6, 2013 at 8:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.