The previous Core version used 2 years ago was 19.0.1. I have since then upgraded to 21.1 last year. The wallet which worked fine with 19.0.1 is no longer loading in 21.1. The database in up to date and the default wallet(empty wallet for 21.1) is loading fine but the previous wallet is making Core close without error messages. Also tried a few copies of same wallet with same result.

Thanks, Christian

  • Are there are any errors logged in the debug.log file? Have you tried a more recent version as 0.21.x is EOL?
    – Andrew Chow
    May 17 at 17:12
  • I found the solution but it should not be this way. Ver. 21.1 forced me to "Create Wallet" (instead of using the default one directly under the Bitcoin folder) and at the same time creating a new sub folder into which I placed my old wallet and it worked. I also re-imported the privkey to create a brand new wallet on ver. 21.1. I will upgrade to the latest version and we'll see how it goes. Many thanks!
    – Christian
    May 18 at 12:05


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.