I'm trying to set up Electrum Personal Server (EPS) to work with Sparrow Wallet and Bitcoin Core. I've followed the standard procedures for the setup, but I've run into some issues.

Setup Details:

  • Bitcoin Core version: 25.0.0
  • Electrum Personal Server version: 0.2.4
  • Sparrow Wallet version: 1.7.8
  • Operating System: MacOS

Steps I've Taken:

  1. I installed Bitcoin Core and ensured it's fully synced.
  2. I installed EPS and configured it as per the docuementation here: https://armantheparman.com/bitcoin-core-full-node-on-mac-os-with-electrum-personal-server-and-electrum-desktop-wallet/
  3. Set up Sparrow Wallet and tried connecting it to EPS.

Issues Encountered:

  1. When I run EPS from the terminal window it throws the error: "Only legacy wallets are supported by this command".

Configuration Details:

  • My bitcoin.conf for Bitcoin Core looks like:
  • My config.cfg for EPS is standard. The relevant lines look like:
    # Electrum Personal Server configuration file
    # Add electrum wallet master public keys to this section
    # In electrum then go Wallet -> Information to get the mpk
    EagleLegacy = xpub6Bnj9xXB1Z23Jjh6nsmdmGs2QZCr2m6LpqmrcyMAQcqSyxGobPjZUzp7n3XyQN3FVTiWqaKjbVogs6RrxBG2yY5xS24vapBH84yMTox5dub

I've already tried searching online for answers, shutting down and restarting Bitcoin Core, restarting EPS, restarting Sparrow Wallet, and using both legacy and SegWit wallets. I'm considering switching to Electrum Wallet, but it seems to me that the issue is with the EPS software not the wallet software.

Has anyone faced similar issues or have any suggestions on how I can resolve this? Any help would be greatly appreciated!

1 Answer 1


switching to an Electrum wallet is a good choice. However, you should change the certificates in the Electrum personal server as they are outdated from March. generate new certificates as follows:

cd EPS/electrumpersonalserver/certs/
rm cert.*
$ openssl genrsa -des3 -passout pass:x -out server.pass.key 2048

$ openssl rsa -passin pass:x -in server.pass.key -out server.key

writing RSA key

$ rm server.pass.key

$ openssl req -new -key server.key -out server.csr


Country Name (2 letter code) [AU]:US

State or Province Name (full name) [Some-State]:California

Common Name (eg, YOUR name) []: electrum-server.tld


A challenge password []:


$ openssl x509 -req -days 1825 -in server.csr -signkey server.key -out server.crt

now in EPS directory:

nano config.ini

The server.crt file is your certificate suitable for the ssl_certfile= parameter and server.key corresponds to ssl_keyfile= in your Electrum server config. Make sure the path of these files is set correctly. Then restart your EPS and it should connect fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.