0

I downloaded Bitcoin Core 25.0. When I try to open my wallet I get this error:

enter image description here

Wallet loading failed. Wallet files should not be reused across chains. Restart bitcoind with -walletcrosschain to override.

Why am I getting that error, how can I stop getting it?

1 Answer 1

1

As the error says, wallet files cannot be reused across chains. This means that the wallet was created with one of the testing chains such as testnet or signet, or created for an entirely different coin. Either way, as the error says, you should not be using the same wallet with different chains as it can lead to errors in the wallet state.

You should instead try to identify which chain the wallet was used with and open it with the software set to that chain or the proper altcoin software.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.